My app suddenly stoped working exit status 7

My app suddenly stopped working and a can’t deploy any more apps.

My log say:

[13:00:08] :exclamation: exit status 7: streamlit-install: ERROR (abnormal termination)

[13:00:08] :exclamation: Error during processing dependencies! Please fix the error and push an update, or try restarting the app.
[13:01:46] :exclamation: Streamlit server consistently failed status checks
[13:01:46] :exclamation: Please fix the errors, push an update to the git repo, or reboot the app.

What is this Abonormal termination?

Maybe you can try some package updates, then push the changes and see what comes up. If it doesn’t solve it after this, deploy the same app from a new testing branch with the new updates (make sure you update the requirements.txt after updating packages if any) and compare the behaviour. You can proceed from that point and on with new insights (if it works just reboot the old app branch with new updates or delet/re-dploy it).

It can be helpful to tell us what you tried first, I can assume you rebooted the app as mentioned in the error logs but since you didn’t mention it yourself I suggested it, it’s helpful so we can suggest possible solutions you haven’t tried yet, cheers.

Greetings, please add all the packages used by your applications in the requirements.txt file and reboot your app again. It should work

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.