Not able to launch streamlit app due to unicodedecodeerror

I have been trying my best to run my streamlit app , but I am unable to launch it in VS code ,
This is the error I am getting :
Traceback (most recent call last):
File β€œβ€, line 198, in _run_module_as_main
File β€œβ€, line 88, in run_code
File "C:\Users\USER\venv\Scripts\streamlit.exe_main
.py", line 7, in
File β€œC:\Users\USER\venv\Lib\site-packages\click\core.py”, line 1157, in call
return self.main(*args, **kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^
File β€œC:\Users\USER\venv\Lib\site-packages\click\core.py”, line 1078, in main
rv = self.invoke(ctx)
^^^^^^^^^^^^^^^^
File β€œC:\Users\USER\venv\Lib\site-packages\click\core.py”, line 1688, in invoke
return _process_result(sub_ctx.command.invoke(sub_ctx))
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File β€œC:\Users\USER\venv\Lib\site-packages\click\core.py”, line 1434, in invoke
return ctx.invoke(self.callback, **ctx.params)
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
File β€œC:\Users\USER\venv\Lib\site-packages\click\core.py”, line 783, in invoke
return __callback(*args, **kwargs)
^^^^^^^^^^^^^^^^^^^^^^^^^^^
File β€œC:\Users\USER\venv\Lib\site-packages\streamlit\web\cli.py”, line 201, in main_run
bootstrap.load_config_options(flag_options=kwargs)
File β€œC:\Users\USER\venv\Lib\site-packages\streamlit\web\bootstrap.py”, line 367, in load_config_options
config.get_config_options(force_reparse=True, options_from_flags=options_from_flags)
File β€œC:\Users\USER\venv\Lib\site-packages\streamlit\config.py”, line 1285, in get_config_options
file_contents = input.read()
^^^^^^^^^^^^
File β€œβ€, line 322, in decode
UnicodeDecodeError: β€˜utf-8’ codec can’t decode byte 0xff in position 0: invalid start byte

python version:3.12.0
streamlit :1.30.0

Hey @kottarivaibhav,

Can you please share a link to your GitHub repo or a runnable code snippet that we can use to reproduce this error?

Generally with any code I am unable to get the output . It shows the following error . It seems to me that certain files have been corrupted but I am unable to guess which file of streamlit is corrupted. The same code used to run few days back , but when I started to use git codes so that I could deploy in heroku all the problems started in the editor

It seems to be a configuration file. See the docs to learn where streamlit looks for such files.