Nothing happens when I click "Deploy" on a new app

I’ve successfully deployed a streamlit app in the past, and wanted to deploy another. However, when I click “Deploy”, I briefly see a spinning blue wheel, then the deploy button is grayed out, but nothing happens.

The app is just a clone of this to my account: gpt-assistants-api-ui/app.py at main · ryo-ma/gpt-assistants-api-ui · GitHub

I’ve tried:

  • Deploying with and without secrets
  • Waiting > 10 minutes after clicking deploy
  • Different browsers (Firefox and Chrome on Ubuntu, Safari on iPad)
  • Different app URLs, in case the first deploy failed but blocked the URL somehow even though it shows Domain is available
  • Using the required python version for the app (3.10), or the latest (3.11)
  • Deploying the original repo above instead of my clone. This instead gives an error “Request failed with status code 403”

Info that may be related:

  • My previous app is visible in my account, but is now read only. I haven’t changed the repo name - I wonder if this is because login behaviour is different now (I used to log in with Google, but now it seems to log me in using Google and GitHub at the same time)
  • The previous app is: https://survive-5.streamlit.app. It’s public, so I shouldn’t be running into the 1 private app quota

Thanks for any help :slight_smile:

Hi @Mohamad ! I can take a look. Would you mind reproducing this and sending me the time when you tried the operation ? UTC time would be great.

Thanks!

Hey, thank you. I tried this again just now at exactly 15:00 UTC and the same thing happened.

It might be related to permissions on the repo - yesterday I got this to work on a public fork of the same repo linked above. Twice now it doesn’t work on a private copy of the same repo and I’ve tried 2 way to make a private fork. Yesterday following this guide (Create a private fork of a public repository · GitHub) and today by just making a fresh repo, and copy and pasting the contents into it.

The app above survive-5 was previously deployed from the private repo. However now if I try to make a duplicate app I get this same behaviour.