On hosted site, Streamlit not using config.toml


On my local version, Streamlit is changing the stylings of the app using config.toml as intended, but when I deploy to the web, it is using the default stylings. I have deployed my .streamlit folder and config.toml, but no luck.

If changes to .streamlit/config.toml are made while the app is running, the server needs to be restarted for changes to be reflected in the app.

Hello @cgfdev,

where are you deploying your app?

Are you deploying to streamlit cloud? Or using a container?

@snehankekre Hi, I have the same problem. When I run my app locally, the custom config.toml gets picked up just fine, however, I have been unable to make it work on streamline cloud.

I have tried both putting config.toml inside .streamlit and to the root of the repo but neither works.

The former gives me error in the management console

[04:37:28] โ—๏ธ Updating the app files has failed: git pull, cmd: sudo -u appuser GIT_SSH_COMMAND='ssh -i /home/appuser/.ssh/id_github -o IdentitiesOnly=yes -o StrictHostKeyChecking=no -o "LogLevel ERROR"' git fetch origin && sudo -u appuser git reset --hard origin/dev: error: exit status 128: error: unable to create file .streamlit/config.toml: Permission denied
fatal: Could not reset index file to revision 'origin/dev'.

The latter passes but falls back to the default theme.

Attached is the screenshot of my repo - dev branch.
Screenshot 2023-05-11 at 12.49.58 PM

And yes, I have also tried the all those obvious things such as rebooting or redeploying my app.


Hi @Jan_Sindlar

Can you share a link to the repo? We can try to deploy and see if we can help to solve the issue.

Best regards,

Hi, thanks for your reply. I created a dummy app from a brand new repo, deployed the app, which worked. Then I went back to my original app, and all of a sudden works!
Mysterious problem is now mysteriously goneโ€ฆ

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.