Problem importing openCV

Dear all,

I am experiencing a problem when importing opencv to my deployed app.
As I saw in several posts, this problem is already known to the community.
However, and although I tried the fixes that other people have used, the problem still persists.
I tried adding opencv-python-headless and I tried to add packages.txt and in it the modules libglib2.0-0, freeglut3-dev

My repo is GitHub - OriBloch/Aircraft-Intelligence-Hub
And the app is

The page that does not work is the Imagery Analysis page.

Thank you all and looking forward for your wisdom in correcting my problem.


Hi @OriBloch . Instead of the following replace it with following:-



Happy Streamlit-ing :balloon:

Hey Guna,
Thank you for replying.
The solution you recommended does not work. this is the current log:

When we are updating the requirements.txt file, we need to reboot the application

thank you very much.
opencv-python-headless worked.

I mistakenly used Rerun instead of reboot.

thank you.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.