Pyodbc SQL Server error

Hi! I am getting a pyodbc error 08001 when my app tries to connect to our SQL Server from Streamlit Cloud. I created a small test app just to test SQL connectivity, and while it works on my local machine, when I run the app on Streamlit Cloud the app fails at the connect string. Is this an SSL issue with Streamlit cloud? I get this info along with the error:
SSL Provider: [error:1425F102:SSL routines:ssl_choose_client_version:unsupported protocol]

Thanks,
Peter

Hi @Peter_Sonenstein,

Can you share the full error message?

Yes, here is the error that comes through:

I should also point out that I run an old version MS SQL Server (2012 SP1).

It looks like there needs to be a change made to the openssl.conf file?

See this resolution to a similar issue : [Microsoft][ODBC Driver 17 for SQL Server]SSL Provider: [error:1425F102:SSL routines:ssl_choose_client_version:unsupported protocol] · Issue #1112 · microsoft/msphpsql · GitHub

Can we get a setting for older SQL servers?

Following up: I ended up connecting my aging SQL Server to another service and then accessing the data through a secure REST API.