Running streamlit locally results in blank page

I run a streamlit app locally and it worked until 1h ago perfectly. I tried to implement an asyncio.Semaphore and then it crashed. I removed everything related with Semaphore again. But it still just shows a blank page. I tried to

  • run the app on another port
  • comment out all code and print a simple “hello world”
  • upgraded streamlit version
  • rebuild the virtual environment
  • restarted my machine

I am running

  • python 3.8.16
  • streamlit 1.28.2
  • on mbp m1 (macOS 13.4)

Any help is greatly appreciated!

Edit:
Maybe this helps someone: Un- and reinstalling streamlit in the virtual env solved the issue for me…

1 Like

Glad it finally worked!

Happy Streamlit-ing! :balloon:

1 Like

same issue. I didn’t have any problems before, but suddenly I’ve been experiencing this situation for the past 2 days. I have no idea what to do.

Have you solved it?

For me reinstalling streamlit in the virtual environment solved the issue. Make sure you are in ure virtual env. Then use

pip uninstall streamlit

and confirm if prompted. Then install again with

pip install streamlit

Let me now if this helped.