Show password button (eye) doesn't work in column

Hello everyone,

Basically what the title says.
If I place a st.text_input widget inside a beta_column using a with statement, the show password button (shaped like an eye) doesn’t work.
Edit: This is observed on Mozilla browser, but not on Chrome.


import streamlit as st

pwdCol1, pwdCol2 = st.beta_columns([1, 3])
with pwdCol1:
    password = st.text_input('Insert password',  value = '', max_chars = None, key = None, type = 'password')

Conda installation on Windows 10 x64, python version 3.7.9, streamlit version 0.72

Hey @Gouyoku,

So the eye on the password is just not there? Can you attach a screen shot?

When you say that its observed on Mozilla but not Chrome you mean that you have tried the chrome browser and it is working (or you haven’t tried it there)?


Hey @Marisa_Smith,

The eye is there, but it does nothing on click; i.e., it neither changes to the eye with a strike on top of it, nor does it make the password show.

When I say that its observed on Mozilla I mean that I have tried on both browsers, but I experience it only on Mozilla. I believe that I have the latest version of both browsers installed, or at least a very recent one.

I cannot run it to provide a screenshot at the moment, but I will do so as soon as I can.
I understand that you are unable to reproduce it?

Thank you for the swift response!

Hey @Gouyoku,

Yes, I have not yet reproduced it (cause I foolishly thought you hadn’t tried it on Chrome).

I will download Mozilla and see if I can reproduce it now that I know exactly what I am looking for. My only issue is I am not a windows user, so if it works for me I will send it onto someone with a windows machine!

Will get back to you soon,

Hey @Marisa_Smith,

I am a dual boot user, so when I get the chance I will test it on my Ubuntu 20 too.

1 Like

Hey @Gouyoku!

So, I have tested a few things out:

I can reproduce the issue with Firefox browser (fresh download), python 3.7.9, and Streamlit 0.72.

Also, when I try with a newer version of Python (3.8.5) I have the same thing. Chrome and Safari work fine, it’s just a problem with the Mozilla browser.

Thanks for finding this and letting us know. I have sent this on internally to get some assistance from our engineering team.


Hey @Gouyoku,

Just wanted to let you know I have created a bug report for this here:

Feel free to add anything else to make it easier for the team to fix!

Happy Streamlit-ing!