Showing psycopg2 error in deploying

when I am deploying it shows an error you can see here

Hey @abhay121-pixel could you show the log. Click on manage app on your bottom right and look for the error and get back with a screenshot. Probably you must be missing a module in requirements.txt

Add PostgreSQL to Path : Error: pg_config executable not found - #2 by devguru - The freeCodeCamp Forum
Check with this

in my system this setting is done so what i do next

Not sure bud. But psycopg2-binary is not used onto production purpose, psycopg2 is only used. Just wait for someone to provide a crisp sol.

Hey @abhay121-pixel
I had a very similar problem to this. While deploying, it gave me the same error message “pg_config executable not found”, and “If you prefer to avoid building psycopg2 from source, please install the PyPi ‘psycopg2-binary’ package instead.”

So that’s exactly what I did. One of the modules in my “requirements.txt” was psycopg2. I changed that to psycopg2-binary, and voila! It worked!