Streamlit app not connecting to remote

Dear Community,
I have a problem with the deployment of my streamlit app on my server. I’m using an NGINX server and port forward from port 80 to the streamlit port (8501) for my specific domain. However my app will be stuck on the “Please wait”/“Connecting” screen.

Things I’ve tried:

  • app works locally
  • deployment on streamlit share works (I need to save some documents from the user input from the app though, so I need it to be deployed on my own server)
  • setting up simple HTTP server with port forwarding works
  • I tried everything on the App is not loading when running remotely — Streamlit 0.81.1 documentation troubleshooting page
  • the problem is independent of the browser I’m using

Any thoughts on what else I can try? The only other option I see is running it on port 80 with root permissions, but I am not sure how exactly I’d do that.

Any hint is highly appreciated, thanks so much!

I actually managed to figure it out finally. I had to open my webserver port 8501 (which I use for my streamlit app) to inbound traffic.

sudo ufw allow from any to any port 8501 proto tcp
1 Like