Streamlit app unresponsive

Hi all,

I have a streamlit app, which for some reason is becoming unresponsive: Whenever I change the value of the dropdown, there is 1-2 second of lag before streamlit starts loading. I have tried to time every bit of my code within the streamlit app, but there is nothing above 0.1 seconds reported by the timing function. It seems that this 1-2 second of lag occur before any of my code is being executed.

Can you please help me understand and debug this case? It is difficult to improve, when I have no way to track what the problem is.

Hi @wolfram, welcome to the Streamlit community!

Can you post a repo that demonstrates this behavior? Is this happening locally on your machine, or is this app deployed somewhere?


This is happening on my local machine. I have several streamlit apps running, but for some reason this one is causing problems. It is a weird lag. When I change the dropdown here is a delay of 2-3 seconds before loading starts to happen. I have tried to time my code from start to end, but nothing in the timer indicates time consumption of more than 0.1 seconds. Could it be related to memory?

I think memory swapping could be a good thing to explore. If you are running several apps, and your operating system is swapping RAM to disk, you could be seeing these sorts of hiccups.