Streamlit_option_menu not working while deployment

i am trying to deploy my streamlit app on the cloud but its showing streamlit_option_menu no module found

Do you have a requirements.txt file in your github repo?

Heyy thanks for replying me, this is my github link to my requirements.txt file
Coal-Mining-Safety-Chatbot/code/requirements.txt at main · Prureddy/Coal-Mining-Safety-Chatbot · GitHub

Well, but you have two reqs files in your repo, one in the root folder and one in the code subfolder, remove one…

yeah I removed it and I checked but its not working again its showing same error

  • do a reboot of the app
  • if no success, any error messages in the web terminal?

again same error only

Why using such old version 0.3.2 of streamlit-option-menu?

I quickly tried this in a docker container and it worked:



import streamlit as st
from streamlit_option_menu import option_menu

It’s working on local but I am facing the issue while deployment what might be the issue

This is my deployment link without option-menu it’s working

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.