Trouble deploying to streamlit cloud

Hello, I am having trouble deploying a forked app to streamlit cloud. In theory, the app should work fine. Here is my github repo: GitHub - xinyang1243/streamlit-10. I also notice the following warning```WARNING: You are using pip version 22.0.3; however, version 22.3.1 is available.


I don't have this message or really any trouble at all when I deploy locally.

![image|690x345](upload://qmO0yYnY5OmX5z20Lyfv96K4Nvf.png)

Are you able to use a newer version of lxml? When I don’t set the version (or specify the latest version, 4.9.1) it appears to install correctly on my test app.

I don’t know how to deal with it here but I do see some references on StackExchange re: needing to manually deal with libxslt and libxml2 in some environments, which are mentioned in your error. I just noticed that the latest version seems to bypass the problem, so thought I’d mention it in case it helps.

So my main problem seems to be that I don’t know where streamlit reads off the python data from. It seems that it is not reading from my computer as the pip versions are different and it is installing libraries that I already have and it is installing version 4.5.1 of lxml while I already had 4.9.1 on my computer.

If you know how to deal with this I would greatly appreciate it :slight_smile:

Streamlit cloud won’t pull any packages off your computer; it’s some kind of container deployed in the cloud and it automatically installs packages from open sources using requirements files.

From your github link, I see this as your requirements file:

streamlit==0.68.1
pandas==0.25.3
base58==2.0.0
matplotlib==3.1.3
numpy==1.18.1
yfinance==0.1.54
lxml==4.5.1

If you change the last line to lxml==4.9.1 or just lxml will you have any compatibility issues with your code? Or are you locked in to making 4.5.1 be the version?

1 Like

Hello! I changed the requirements txt file and it worked like a charm! It seems that there is a problem with streamlit using older versions of libraries which is a bit disappointing. But thank you for your help nonetheless!

There is no such a problem with streamlit, it was your requirements.txt what was pinning the older versions.