Using Streamlit to display url without port


I have created an app using Streamlit which runs successfully on localhost (personal laptop) and also on my university server. But the problem is, after I run the Streamlit python code, it generates the URL something like HTTP://localhost:8501 (if run on a laptop) or HTTP:// (if run on the server).

My university has an HTML page where relative URLs are created and all the apps are accessed through that soft link. When anyone clicks on the name of the app (not the one I created), it will redirect you to the webpage with the URL HTTP://nameofthegroup/apps/app1.

If anyone clicks on the name of the app which I have created, it will redirect to the webpage with URL HTTP://nameofthegroup:8501

You see the difference!! I want it to be something similar to HTTP://nameofthegroup/apps/app2 instead of display of port number 8501 in the URL.

Can anyone please please please help me resolve this issue? I want to avoid the port number 8501 in my URL. I’ve been struggling to set it up for a real long time now.

You can try using port 80 instead, but your best option is seeking support from the IT people at your university.

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.