50MB dataset limitation when using Plotly.py

Hi there,

I’m using Plotly.py to show figures in my Streamlit app with big datasets. And now I get a notification of dataset oversizing, bigger than 50.0MB, is there anyway to solve this?

the exact error message is “RuntimeError: Data of size 83.4MB exceeds write limit of 50.0MB”

Check this:

Thanks for the reply! I found this github link before I posted this issue, but it didn’t solve my problem.

But later my friends and I found this error message in ~/site-packages/streamlit/server/server_util.py, and changed the parameter MESSAGE_LIMIT_SIZE to 200*1e6, making the write limit now 200 MB

1 Like

@imClumsyPanda I did the same, but it still doesn’t work for me.
Please any help

Hi,

Have you tried to re-do streamlit run again after the file changed and saved?

1 Like

Yes, i rerun the app again but still doesn’t work.
Please, i have another question is their in posibility to run a file with GB size.

If you mean upload file with GB size, you can try “streamlit run xx.py —server.maxUploadSize=1028”

Do you have multiple python environments? That might cause the modification doesn’t work well

1 Like

No i have only one envirement

You can use “where streamlit” command to check if the streamlit.exe is in the same path with the server_util

2 Likes

Thank you for your response. Actually when i restart my machine it works.
And i can display data up to 200 Mo