RuntimeError: Data of size 107.9MB exceeds write limit of 50.0MB

I am getting this error when offering a download link. Is there a way to increase this limit? I am dealing with data much bigger than 100MB.

Hi @Soren,

If you’re using the download link trick, then you’re out of luck when dealing with larger files :confused:

The preferred method for now is dropping the data into Streamlit’s static folder and create an URL which links back to it. Several approaches are described in this thread.

Best of luck!
Fanilo

1 Like

Thank you!!

Hi,

I am getting the same error while trying to plot an obviously too large Altair chart. Is there a way to capture this error and simply skip processing?

Thanks

Fabio

I solved it by simply sampling the dataset that generates the plot.

Hi Fabio, can you share your solution?

Hi

I simply used df.sample to make my dataframe smaller.

Best

Fabio

Hi Fanilo,

is there any way to solve the same error message when trying to plot a large dataset

1 Like

I am also getting an the same size error for a plotly chart. I’m not sure how or why, considering I have similar charts with similar amounts of data that do work.

finally solved this by searching this runtimeerror info in site-packages/streamlit/serverutils.py.

Just change the parameter which is now 50*1e6 to bigger one and restart your streamlit service.

My streamlit apps work well after changing that, you may have a try!

Dan via Streamlit <streamlit@discoursemail.com>于2021年2月6日 周六上午6:13写道:

Well, I don’t seem to have that exact file path… I got to site-packages/streamlit but then there’s a server folder and a file call server_util.py, so it ends up being
site-packages/streamlit/server/server_util.py

I opened that up and saw there is a MESSAGE_LIMIT_SIZE value of 50*1e6. I changed that but am still getting the error for 50MB. I’ll keep digging around and see what I can find, but if anyone has any ideas, please let me know.

Thank you

Sorry, site-packages/streamlit/server/server_util.py is exactly what I meant, sorry for the unclear path.

After changing MESSAGE_LIMIT_SIZE, I started a new cmd.exe and run “streamlit run xx.PY” command. And now the error message no longer appears with 50.0MB Limit

Dan via Streamlit <streamlit@discoursemail.com>于2021年2月6日 周六上午10:09写道:

1 Like