'apache-arrow' module not found error

Hello,

I created a custom component, but when I run npm start, I get an error below:

export 'Table' (imported as 'Table') was not found in 'apache-arrow' (module has no exports)

My component doesn’t use Table. I’m not sure how to resolve this issue. Could someone please help? I’ve upgraded both Streamlit and npm.

Thank you!

I’ve upgraded both Streamlit and npm.

I had the same error. I was able to fix it (after a lot of effort) by minimizing the differences in the package.json dependencies when compared to the original streamlit-component-template. I suggest to copy the dependencies from Streamlit’s package.json to your own project to start.

1 Like

@Amit_Kumar, Yes, I copied the dependencies from the package.json in Streamlit template project, and it worked! Thank you for sharing.

The offending package is react-scripts. There is a related issue: https://github.com/streamlit/component-template/issues/23. All you need is downgrading react-scripts in package.json to version 4.0.1 (any other 4.x.x will probably do the job as well.).

After the downgrade I ran into https://stackoverflow.com/questions/69665222/node-js-17-0-1-gatsby-error-digital-envelope-routinesunsupported-err-os, which can be solved using the answer of romellem.