App loading problem

hi… I tried to run the uber.py app,which is there in the instruction on streamlit.io but every time I run the app through the command prompt it gives me this error :

NameError : name ‘null’ is not defined

File “c:\users\rashi\anaconda3\lib\site-packages\streamlit\ScriptRunner.py”, line 306, in _run_script exec(code, module.dict)

File “C:\Users\rashi\uber.py”, line 5, in “execution_count”: null,

Im using stream lit version:0.47.2 and I tried using the latest version as well 0.47.3

python version: 3.7.3

can someone helo me with this problem?

Hi adeell

I’m having trouble reproducing your bug on my machine. So I dug around the codebase for both Streamlit and the Uber demo, and couldn’t find anything about execution_count. After a Google search it seems that execution_count is a variable that Jupyter keeps for each of its cells.

Which makes me wonder: can you explain in a little more detail what your setup looks like? How are you running the Uber app? Are you running Streamlit from inside Jupyter somehow?

hi Thiago

thanks for the reply
well after writing the code I downloaded the file as a .py file on my desktop and ran “Streamlit run uber.py” in my terminal after which I get the following feedback "

You can now view your Streamlit app in your browser.

Local URL: http ://localhost:8501

but when it opens I get the execution_count errors, I tried running it without downloading directly from Jupiter but the same error occurred

Hi @adeell: Can you please share the exact error message you’re seeing, including the full stack trace?

Also, on the off-chance that this might tell us something, can you please make sure that Jupyter isn’t running when you streamlit run uber.py from the command line?

hey @Adrien_Treuille
thanks for the reply
the issue got fixed once I uninstalled and then reinstalled Streamlit…there seems to be no more issues

1 Like

Hello,I have the same problem!
O the command line:
Last login: Mon Nov 4 13:03:18 on ttys001

(base) MacBookProdeMacBook-Pro:~ macbookpro$ streamlit run st.ipynb

You can now view your Streamlit app in your browser.

Local URL: http://localhost:8501

Network URL: http://192.168.1.100:8501
On the localhost
NameError : name ‘null’ is not defined

File “/Users/macbookpro/anaconda3/lib/python3.6/site-packages/streamlit/ScriptRunner.py”, line 311, in _run_script exec(code, module.dict)

File “/Users/macbookpro/st.ipynb”, line 28, in “execution_count”: null,

Hi @ZoranDaiand welcome to the forum :wave:

Streamlit is meant to be run directly against python scripts, not Jupyter notebook files.

Could you try running the following and if you’re still having issues, let us know.

streamlit run https://raw.githubusercontent.com/streamlit/demo-uber-nyc-pickups/master/app.py

Thanks!

I’ve also added a feature request so that future users are less likely to encounter this failure mode in the future. :heart: