Blank Screen From Docker Deployment

Hi there,

I have been struggling all day trying to deploy my streamlit app on Google Cloud Run. My app runs fine on my system (although taking a while when it first loads) but after being built into a docker image I run the app and face a blank dashboard.

There are two lines of code that must run first.

st.set_page_config(page_title="Startup Info Chat", page_icon="🚀")

However, I’ve also noticed that the page icon and title also do not change.

It seems like something is blocking it from running but no error logs are appearing so its difficult to know why this is happening. I am using pinecone which normally takes a little while to load the vectordb and create the retriever for my qa agent but this process isn’t occurring it just seems that the code isn’t running.

I had a similar problem when deploying on streamlit cloud but I was advised by the service that it was due to a lack of ram. When run on google cloud the docker behaves the same way.

At a bit of a dead end and would appreciate any suggestions.


Hi @NickC

Have you tried the Debug console in Google Chrome to see potential errors with rendering the app

You can access this as described in the link below:

Hope this helps!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.