Cloud streamlit will not load plotly_express

My app works locally. Installation error:

Collecting plotly_express
Downloading plotly_express-0.4.1-py2.py3-none-any.whl (2.9 kB)
Collecting streamlit`
Downloading streamlit-1.27.2-py2.py3-none-any.whl (7.6 MB)
ERROR: Could not find a version that satisfies the requirement collections (from versions: none)
ERROR: No matching distribution found for collections
You should consider upgrading via the '/home/appuser/venv/bin/python -m pip install --upgrade pip' command.

I don't know what this means. I built the app using the latest version of pip.

Checking if Streamlit is installed
[16:59:05] โ—๏ธ installer returned a non-zero exit code
[16:59:05] โ—๏ธ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.
[17:00:41] โ—๏ธ Streamlit server consistently failed status checks
[17:00:41] โ—๏ธ Please fix the errors, push an update to the git repo, or reboot the app.

Hi @WorthingtonR! :wave:

Plotly Express should work seamlessly with Streamlit.

I noticed streamlit-1.27.2-py2.py3-none-any.whl in the error log trace. Could you please share your requirements.txt file?

Thank you,

The streamlit cloud works differently than No problem with the requirements.txt file. I modified the file to include only these files and it worked:




Was able to access my script easily after that.

Thanks for the quick response.



1 Like

Glad it worked for you!


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.