Disable analytics sent by streamlit heapanalytics.com

[browser]

# Internet address where users should point their browsers in order to connect to the app. Can be IP address or DNS name and path.
# This is used to: - Set the correct URL for CORS and XSRF protection purposes. - Show the URL on the terminal - Open the browser
# Default: 'localhost'
serverAddress = "localhost"

# Whether to send usage statistics to Streamlit.
# Default: true
# The value below was set in C:\Users\username\.streamlit\config.toml
gatherUsageStats = false

# Port where users should point their browsers in order to connect to the app.
# This is used to: - Set the correct URL for CORS and XSRF protection purposes. - Show the URL on the terminal - Open the browser
# Default: whatever value is set in server.port.
serverPort = 8501

I have already disabled gatherUsageStats but every few seconds a request is made to heapanalytics.com

Is there anyway I can disable this ?

1 Like

Cleared the site data using chrome devtools >> application >> storage >> clear site data

Looks to have solved it. I no longer see any requests made to heapanalytics.com. I’m guessing this was a cached JS that was causing this behaviour.

1 Like