Disabling */index.html redirect for certain paths in cloud deployment

Hi, I’m trying to use the auth_0 streamlit component to implement Auth0 login in my streamlit app. This requires me to set “http://YOUR_DOMAIN/component/auth0_component.login_button/index.html” as a callback site, which works locally when YOUR_DOMAIN is localhost:8501, but doesn’t work when I use the streamlit cloud provided domain for my project.

When I get request localhost:8501/component…/index.html, it returns the component, but when I do it for the streamlit cloud deployment, it redirects the page to the url without the html extension, which then returns an empty page that says “read error”.

Would it be possible to disable this redirect or override it for this particular instance?

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.