Empty page after upgrading streamlit to 1.29.0

  1. Are you running your app locally or is it deployed?
    App is running locally
  2. If your app is deployed:
    No
  3. Share the link to your appโ€™s public GitHub repository (including a [requirements file]
    GitHub - jschaef/sarfile_analyzer_ng: Fork of https://github.com/jschaef/sar_file_analyzer. Replaced Pandas with Polars for most dataframes
  4. Share the full text of the error message (not a screenshot).
    There is no error message at all
  5. Share the Streamlit and Python versions.
    streamlit-1.29.0, python 3.11

My app has some submenuโ€™s which are changing the body of the page. Similar to having different pages. The menu contains something like

  1. display func1
  2. display func2
  3. display func3

Each time I run func2 after func1 the page will render empty.
If I run func 3 and afterwards func 2 it works. Same for func1 โ†’ func3 โ†’ func2 which
is also working.

I have no clue how to debug that because no errors occur on konsole nor on the web page. When downgrading to streamlit 1.28.2 everything is working as expected.

streamlit 1.28.2:

streamlit 1.29.0