Erro running app with libc6

My app is running perfectly but one day, an error appears. It is something related to an installation but I can not solve it. Here is the log from app: ```
[19:23:12] :octopus: Pulling code changes from Github…

[19:23:13] :package: Processing dependencies…

[19:23:13] :package: Apt dependencies were installed from /app/dxrare/packages.txt using apt-get.

Hit:1 Index of /debian bullseye InRelease

Hit:2 Index of /debian-security bullseye-security InRelease

Hit:3 Index of /debian bullseye-updates InRelease

Hit:4 Index of /debian/10/prod/ buster InRelease

Hit:5 Index of /debian-security stable-security/updates InRelease

Reading package lists…[2023-06-26 19:23:14.737271]

Reading package lists…[2023-06-26 19:23:15.248299]

Building dependency tree…[2023-06-26 19:23:15.414307]

Reading state information…[2023-06-26 19:23:15.414754]

libc6 is already the newest version (2.31-13+deb11u6).

Some packages could not be installed. This may mean that you have

requested an impossible situation or if you are using the unstable

distribution that some required packages have not yet been created

or been moved out of Incoming.

The following information may help to resolve the situation:

The following packages have unmet dependencies:

libx11-6 : Depends: libc6 (>= 2.34) but 2.31-13+deb11u6 is to be installed

E: Unable to correct problems, you have held broken packages.

[19:23:15] :exclamation: installer returned a non-zero exit code

Here is my packages.txt: 

Hey @herferjos !!

You can have a look at this Python package to get more information about libc6 in the readme.

Then you can update the requirements.txt with the appropriate version in as mentioned in the error to get it resolved.


Hope it helps. Thanks!

Hello @srini047 !

Thanks for you answer. I have tried to add:


but it is still not working.

Do you know why?

You could try:


Because as per the error, it requires this version. Maybe this might come to the rescue.


Still the same error :frowning: Maybe I have to add some files to force the enviorment to install this version. I dont know too much about these process

Okay! Then someone from the team would be better able to provide the solution.

I’ll make sure to get them in touch with you.

Hope it helps. Thanks!

This might be related to the transition from Debian buster to bookworm, which caused a lot of issues. Try deleting your application and deploying it again. Don’t try forcing specific versions of Debian packages, that is unlikely to help in this context.


This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.