Error deploying on streamlit cloud - "Request failed with status code 400"

Hey there, I’m trying to deploy a simple app from a repo on streamlit cloud and I get the following error when I click “Deploy!”

Any thoughts on how to go about fixing it? There’s no guidance on debugging this.

Request failed with status code 400

Hey @nukebro,

Thanks for sharing this question! Are “main” and “app.py” correct? What happens if you try deploying by supplying your repo’s URL instead =?

Yes! It’s the main branch and the entrypoint/streamlit script is app.py. It’s a private repo, but I took a screenshot.

It does call on a .env file for the API it uses, not sure if that matters.

And I get the same error trying to deploy via the github url. Does the specific error code mean anything?

Super interesting – do you mind DM’ing me your GitHub username? Also, have you deployed any other private apps on your account?

Will send a DM now - this is my first time trying to deploy on streamlit cloud, so I’m sure have some setting in git wrong :upside_down_face:

@Caroline just kidding, I don’t know to DM on here

If you click on my profile there should be a “Message” button in the top right corner

It looks like I’m limited as a new user and can’t send messages?

Hello, I am facing the save error, did you find a way to solve the issue by any chance?

5 posts were split to a new topic: “Request failed with status code 400” error when deploying

Hi, I’m experiencing this as well when trying to deploy. I am also unable to send you a DM, the option does not appear.

Hey @andersbennaes, can you share the info in this thread instead?

Can you share the link to the GitHub repo that you’re trying to deploy from?

@Caroline Unfortunately I can’t, but I sent you an email. Cheers

Hey there,
I’m reaching out because I’m having a bit of trouble understanding why this particular issue is classified as super interesting. This issue has been a part of Streamlit from the beginning.

Just to give you a bit more context, I recently deployed a very basic app which allows users to upload csv files. I used Streamlit 1.31.0 and a Single Docker container on Azure as a web app service, but I encountered the same error.

Could you possibly guide me towards a solution for this?

Thank you in advance for your help and support.

Hi @cmbkr,

It sounds like the error you’re describing is different from what this thread is focused on, which is seeing a 400 error when deploying on Streamlit Community Cloud (you mentioned you’re deploying your app with Azure). Do you mind creating a new post in the “Deployment” category for your question?