Error installing requirements...blpapi

New to Streamlit here. Was working off fredapi and managed to run it in streamlit. for the current dashboard, keep getting this error. the only difference is the blpapi and it says version = none. Any suggestions pls?