Error installing requirements & ModuleNotFoundError

Hi Streamlit Community!

I faced the following problem when I was trying to deploy my app on Streamlit.

I have with me

  1. requirements.txt

  2. packages.txt

May I know what can I do to fix this error?

Thank you!!

Remove the packages.txt file, you don’t need those packages and they even don’t exist at all.

Hi Franky! Thanks so much for your response!

I have deleted the packages but I get a "ModuleNotFoundError: This app has encountered an error. " instead.

This is at the top of my

I only have requirements.txt and file.

Is there something I am doing wrongly? Please advice! Thank you!!

Please share your public github repo link, otherwise we can only guess.

1 Like

Hi Streamlit Community!
Unfortunately, I have the same problem. My both apps are not working, although two weeks ago everything was fine. For example, the application /. Today I tried to open it, but I got an error

I can’t delete the file packages.txt , since the py3Dmol module will not work without it.
My link to the project on github: GitHub - ovttiras/HDAC6_detector
Thank you in advance!!!

Based on the error message, I suspect a temporary hiccup in the apt repositories. Try a redeploy again.

1 Like

@Franky1 Sure! Here is my Github Repo: GitHub - jedlwk/streamlit_project

Hi @Franky1 ! Sorry for bumping you but could you help take a look at this for me? Thank you!!

You don’t have a requirements.txt file.

1 Like

Hi @Goyo . I am terribly sorry about this rookie mistake I made. Thanks for spotting that for me and my app works now! Thanks so much!!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.