ERROR: No matching distribution found for sklearn==1.1.2

ERROR: Could not find a version that satisfies the requirement sklearn==1.1.2 (from versions: 0.0)
ERROR: No matching distribution found for sklearn==1.1.2
WARNING: You are using pip version 22.0.3; however, version 22.2.2 is available.
You should consider upgrading via the ‘/home/appuser/venv/bin/python -m pip install --upgrade pip’ command.
Checking if Streamlit is installed
I was making this project and when i deploy the app i am having this error and i am not able to resolve it and i have a requirement file too

Hi @Aarush, welcome to the Streamlit community! :wave: :partying_face:

sklearn==1.1.2 does not exist: sklearn · PyPI

You should use scikit-learn==1.1.2 instead in requirements.txt: