Error on my deployment in streamlit


I tested the snowpark connection and it worked ( I looked up the query_history in Snowsight, it shows the query I queried in the python code). But the app keeps saying Oh No.

Can anyone please help?


Does it works locally? Did you configure the secrets while deploying the app on streamlit cloud?

The “Oh No” message in your application suggests an issue in your code or logic. Start by checking application logs for error messages. Review your Snowpark code for proper error handling and ensure query accuracy. Check network and firewall settings for potential disruptions, and confirm compatibility with your deployment environment.

My code doesn’t have problem because I tested them line by line.

The connection with snowpark worked because I checked that the query I ran via snowpark showed up in the Query History with Success status.

But the streamlit is not showing anything.

Can you share your repo so we can have a look at the code? Also try redeploying the app because it seems like a deploying issue else the home page will render some text first (if you have some st.write statements).

I just checked again.

The streamlit showed me the following error. How can I resolve that ?

[10:29:01] :package: Processed dependencies!
Collecting usage statistics. To deactivate, set browser.gatherUsageStats to False.
/home/adminuser/venv/lib/python3.9/site-packages/snowflake/connector/ UserWarning: You have an incompatible version of ‘pyarrow’ installed (13.0.0), please install a version that adheres to: ‘pyarrow<10.1.0,>=10.0.1; extra == “pandas”’


Yea, here is my repo. The code after line 21 is the part that is not working

Please check! Thanks!

Seems like a pip dependency error for pyarrow, can you add this in requirements.txt:

You can install locally using:
pip install pyarrow==10.0.1

1 Like

Thanks very much for your help Navin. My app is working now!!!

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.