Error When Connecting GitHub to My Account


I’ve opened up my cloud account today, but when I try and link my GitHub account it gets to the screen below.

I am using a Raspberry PI, with Debian standard install and a long-standing/active GitHub account.

Any clues greatly received!


Hi @PositivePython
The issue you’re encountering, where the GitHub linking process appears to be stuck or not progressing as expected, can be caused by a few factors. Here are some steps you can take to troubleshoot and resolve the problem:

Check Your Internet Connection
Browser Compatibility
GitHub Account Permissions
Clear Browser Cache
Try a Different Device
Check for Browser Extensions
GitHub Status
Firewall or Security Software
JavaScript Enabled
Try SSH Instead

The answer will be from above mentioned points, please make sure you have completed all the steps properly. I hope this will help you regarding this problem
Thank you

Many thanks Abdul. I’ll trawl through the documentation, just in case do you know a link to a document that summarises what needs to be in place for the link to GH to work?

I have tried

Using different computers (Windows/Linux/Android)
Different browsers Chrome and Chromium
I removed all GitHub integrations
Cleared cache/cookies/passwords for all time!
Removed Browser extensions
I have no firewall
Javascript is enabled
My GitHub Account is a personal one, so I am default admin.

Have scoured the documentation and still can’t find a cause for this error. Anyone out there with a similar experience?

@PositivePython you can try deleting the app in the cloud and host it again, if it is not working, it is possibly that your github repo is private, Streamlit cloud have a limit of deploying only one private app, you can try to make your repo public

Hi @Melo04 thank you that is a great suggestion.

The problem is that I don’t even get as fat as hosting an app. My account won’t connect to GitHub to see my repo. All my repos are public (PositivePython (Sean Massey) · GitHub) but I think there is a problem with my core account settings that is preventing CC connect to GH. I set up a completely different GH account and everything worked first time, but I would prefer to use me existing account so I can keep my commit history!

Are you sure your github account exist, i click on the link to your github in the comment that you have sent and it shows webpage not found error:


We couldn’t make it work at the GitHub end and they’re support team just couldn’t find a reason. So I moved all my repos to a new GitHub account and community cloud works fine on the new account. Have lost my commit history though…ah well…

Thank you for helping me.


Join the Python community at

This topic was automatically closed 180 days after the last reply. New replies are no longer allowed.