Error when deploying app in streamlit cloud that doesn't appear when run locally

I have an app that works via streamlit when it is run locally. However, when I try to get it to run via streamlit cloud I get this error. I tried setting the python version but still can’t see what’s happening.

2022-09-23 21:52:33.091 Uncaught app exception

Traceback (most recent call last):

  File "/home/appuser/venv/lib/python3.7/site-packages/streamlit/runtime/scriptrunner/script_runner.py", line 562, in _run_script

    exec(code, module.__dict__)

  File "/app/facedash/pages/03_Face_Expression_Analysis.py", line 305, in <module>

    f.run()

  File "/app/facedash/pages/03_Face_Expression_Analysis.py", line 301, in run

    self.facial_action_units()

  File "/app/facedash/pages/03_Face_Expression_Analysis.py", line 218, in facial_action_units

    'AU43']]

  File "/home/appuser/venv/lib/python3.7/site-packages/pandas/core/frame.py", line 3464, in __getitem__

    indexer = self.loc._get_listlike_indexer(key, axis=1)[1]

  File "/home/appuser/venv/lib/python3.7/site-packages/pandas/core/indexing.py", line 1314, in _get_listlike_indexer

    self._validate_read_indexer(keyarr, indexer, axis)

  File "/home/appuser/venv/lib/python3.7/site-packages/pandas/core/indexing.py", line 1374, in _validate_read_indexer

    raise KeyError(f"None of [{key}] are in the [{axis_name}]")

KeyError: "None of [Index(['input', 'AU01', 'AU02', 'AU04', 'AU05', 'AU06', 'AU07', 'AU09', 'AU10',\n       'AU11', 'AU12', 'AU14', 'AU15', 'AU17', 'AU20', 'AU23', 'AU24', 'AU25',\n       'AU26', 'AU28', 'AU43'],\n      dtype='object')] are in the [columns]"

main

leftspoonfish/facedash/main/Face_Dash.py