Failure to deploy

Hi, trying to deploy first app and I’m seemingly running into an error “Preparing metadata” for suds-jurko. The app runs fine locally. Any advice greatly appreciated!

repo: GitHub - msparacino/SNOTEL_v1: beta test for DW SNOTEL

It seems to be some dependency error between setuptools and suds-jurko. Maybe if you update to the latest version of all libs could resolve.

But, if you put this in requirements.txt could resolve your problem.

setuptools==58.0.0

Thanks, but that didn’t solve the issue. I saw that thread before I started this one; I previously tried adding setuptools==58.0.0 to requirements.txt without luck. I’ve updated the version of requirements.txt in the repo.

You are right. I tried to replicate your requirements.txt in my project that is using Streamlit Cloud and I had the same issue. After some tests, I found that the problem is in ulmo lib. Reading the git repository of ulmo, I found that this is a known issue.

I tried a lot of things, but any of them was enough to resolve this. Some of my tests:

  • Using suds-jurko==0.5
  • Using suds-jurko==0.6
  • Using setuptools==56.2.0
  • Using setuptools==57.5.0
  • Using setuptools==58.0.0
  • Using setuptools==63.2.0

Maybe if you try some combination of setuptools and suds-jurko you could resolve this issue, but my personal recommendation is maybe you can try to get and transform data without using ulmo. This lib has suds-jurko, that is a project that no longer receives an update (since 2014) and is a known generator of dependencies conflicts and problems

Removing Ulmo fixed the problem. Thank you!