Fatal: could not read Username for 'https://github.com'

Hello!

When I checked on the dashboard this morning to reboot due to an existing error, after rebooting streamlit could not connect to the repo and I receive this error. (I had not made any changes to the app’s code on the main branch of my repo in a week.)

I have tried rebooting and I have tried deleting and recreating the app. All end up with the same error. I have also posted on this thread: Fatal: could not read Username for 'https://github.com': terminal prompts disabled but thought the discussion may be useful in the Streamlit Cloud board.

This is on a private organization repo.

I believe it’s related to Streamlit updates because, as of this morning that I’ve seen, I now have to choose a Workspace when creating dashboards in the Streamlit app. So, all the dashboards are under my organization Workspace instead of my name. I’m not sure if that changes the app’s permissions level?

2 Likes

Thanks for reporting this @fergusonrae

I’ve not come across that problem before, but I’ll liaise with our Devs now to find out what may be happening.

Thanks,
Charly

1 Like

Awesome, thank you Charly!

I’ll add for more context, this might all be expected, but when I first rebooted and received the error, I was able to still see Streamlit’s public deploy key for the main branch in my repo settings. After deleting and recreating the app, the public deploy key was removed and has not been re-added.

Sorry, one more comment for additional context.

I have 3 dashboards linked to the same repo. main, develop, and a feature branch.

  • I rebooted main, I receive this error. I delete and recreate main, and I receive this error. Public deploy key was removed from repo.
  • Feature branch I left alone and it worked fine until this morning when I tested rebooting it. It now has the above error. Public deploy key is still visible in repo.
  • Develop I have not touched. It is still running normally.

So, this issue definitely comes up only when rebooting or restarting the app. Existing apps work fine for me.

1 Like

Thanks for the addendum, Rachael. I’ve reported the info.

We’ll come back to you soon.

Best,
Charly

1 Like

Hello again!

One more bit that may be useful. I pushed changes to the main branch in my repo. Streamlit then tried to pick up these changes and provided the below error:

[manager] Git pull failed: Git pull, cmd: sudo -u appuser  git fetch origin && git reset --hard origin/main: error: exit status 128: fatal: not a git repository (or any parent up to mount point /)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).

In case the error is of interest!

For anyone still experiencing issues

I also received the following error code. This one was occurring in the feature branch I mentioned above

Please make sure you have the correct access rights
and the repository exists.

[manager] Cloning into 'modeled-survival-dashboard'...
Load key "/home/appuser/.ssh/id_github": invalid format
git@github.com: Permission denied (publickey).
fatal: Could not read from remote repository.

In my repository, the public key for the feature branch did exist.

I manually deleted the deploy key from my repo, rebooted the app, and it is now working!

Then, to get main back up, which did not have a public key in my repo, I deleted and recreated the app. And it now works! I am not sure why, I did not follow any steps differently than in previous days.

@Charly_Wargnier are you aware of any updates the team did over the weekend to help resolve this?

Glad to know it’s now working for you Rachael!

Yes, Devs confirmed on Monday about the fix. :raised_hands:

Should you have any questions please do not hesitate to ask :slight_smile:

Best,
Chaly

1 Like