Getting error while running my app

ERROR: Cannot install -r /app/naive-resume-matching-1/requirements.txt (line 58) and mistune==2.0.3 because these package versions have conflicting dependencies.

The conflict is caused by:
    The user requested mistune==2.0.3
    nbconvert 6.5.1 depends on mistune<2 and >=0.8.1

To fix this you could try to:
1. loosen the range of package versions you've specified
2. remove package versions to allow pip attempt to solve the dependency conflict

ERROR: ResolutionImpossible: for help visit
WARNING: You are using pip version 22.0.

As the error message clearly states, there are unresolvable version conflicts with the pypi packages to be installed. But without seeing the code, I can’t help there.
However, I suspect that the requirements.txt is full of unnecessary packages.

I am a learner and trying to use an existing solution for my needs here… how do i resolve the version conflict in Streamlit? please help… The code repo link is:GitHub - srbhr/Naive-Resume-Matching: Text Similarity Applied to resume, to compare Resumes with Job Descriptions and create a score to rank them. Similar to an ATS.

The solution is not requesting mistune==2.0.3 and nbconvert==6.5.1 at the same time.

A more general, long-term solution would be requesting only the packages that you actually need.

1 Like
  1. But this is not your own actual project.
  2. As i suspected, the requirements.txt file is full of unneeded packages.
  3. Clean up the requirements.txt file, only use the packages that you actually import in the application
1 Like