Issue with deploying app in streamlit cc because of these package versions have conflicting dependencies

Hi Team,

I am getting below error while deploying RAG application in Streamlit CC. The app working fine in local as well as Streamlit codespace. Please find the error below:

ERROR: Cannot install -r /mount/src/streamlit_app/resume/requirements.txt (line 2) and pillow==10.2.0 because these package versions have conflicting dependencies.

The conflict is caused by:
    The user requested pillow==10.2.0
    streamlit 1.27.0 depends on pillow<10 and >=7.1.0

However, I have checked the version in local - below are the versions of the packages.
image

Any suggestion to resolve this will be helpful.

Thanks.

Hi @Atanu_Das . It means streamlit 1.27.0 depends on 7.1.0<pillow<10. It’s better to downgrade the pillow version to their specified.

The best way to solve it is probably upgrading to a more recent streamlit, unless you have a very good reason not to do it.