Git pushes and updates done on Codespace won't update the app deployed

If you’re creating a debugging post, please include the following info:

  1. Share the link to the public app (deployed on Community Cloud).
    Here is the link: https://ukrainian-ai-chatbot.streamlit.app/

  2. Share the link to your app’s public GitHub repository (including a requirements file).

Here is the problem:
When I edit and push my code through code space I get an update in my local terminal that the issues are resolved, but the moment I try to access my app link , the same first issue is always up there, even though I have fixed it several times in code space. I have tried to delete the app and make it again, I have also tried to disconnect my github account several times and reconnecting as I have read one earlier forum posts, yet still nothing changes.

I am using this app as a template: How in-app feedback can increase your chatbot’s performance
and I have tweaked it a little bit to suit my own purpose.

  1. Share the full text of the error message (not a screenshot).
  2. Share the Streamlit and Python versions.

Hi @Shir_darec,

Thanks for sharing this question!

The app is throwing this error:

ModuleNotFoundError: This app has encountered an error. The original error message is redacted to prevent data leaks. Full error details have been recorded in the logs (if you're on Streamlit Cloud, click on 'Manage app' in the lower right of your app).
Traceback:
File "/home/adminuser/venv/lib/python3.9/site-packages/streamlit/runtime/scriptrunner/script_runner.py", line 541, in _run_script
    exec(code, module.__dict__)
File "/mount/src/ukrainian-ai-chatbot/main.py", line 17, in <module>
    from langchain_community.vectorstores import Chroma

From this error, it seems you have not added the langchain-community package in your requirements.txt. Add this to your requirements file then reboot the app so it loads the new module.

langchain-community