I am getting this error when I am trying to run locally

I am using Pycaret =2.3.5 and Python =3.8 version. Please help me to resolve it.

This is my github repo

please help

Since you are getting ModuleNotFoundError with pycaret, it means that you don’t have pycaret installed within the same environment you are using to launch your Streamlit app.

From a new terminal, before you streamlit run your_app.py, type pip list to confirm what modules are there. If you don’t see pycaret, do a pip install pycaret, otherwise proceed with your streamlit run command in that same terminal to see if you still get that error.

After typing pip list , I saw I have the pycaret package as seen in the screenshot.

After that I ran streamlit run and I am still getting same error.

@moderators Need your assistance in debugging this.

Thank you for your help.

Hmmmm… I haven’t used pycaret, so can you try a few other things to test the waters:

What if you just type

import pycaret

in a terminal? Does it correctly import that way?

What about:

import pycaret.regression

Since the issue is with importing something other than Streamlit, I’m not sure this has any relation to Streamlit. Can you check if your environment is able to import pycaret into a notebook, or some other script not involving Streamlit? If it has issues there, then I’d think there was maybe something with the environment or the installation of pycaret. You might need to create a new environment or reinstall pycaret if maybe something got corrupted…

@Astha_Sinha please do not tag moderators in your post. Thanks!

I have this issue popping up.

Any help would be apprecated. I rebooted and reinstalled the environment.

I think your model was stored using an older pycaret, in a way that is not compatible with the version you have installed now.