Iframe on ios comes out blank

webapp is deployed and public
webapp shows great in iframe on external website on desktop and android phones, comes up blank on ios phones. Any fix for this? I believe it has to do with the third party cookies the webapp is trying to send (I assume from Streamlit, def not my app).
Changing the setting on the phone is not an option.

Hi @agiveon ,

This was a bug caused by 1.18. If you update to 1.18.1, that should be fixed as mobile uses safari and streamlit wasn’t showing embedded apps in 1.18.

Thank you! Can you tell me what to update? And how? (Newbie here)

Here is an example where it’s broken

(View on iPhone)

Hi @agiveon ,

it looks like you’re hosting an app on streamlit cloud and then embedding that app onto another domain.

Do you have a repo for the code? Usually you can run pip install streamlit --upgrade but since it’s on the cloud, you might need to just restart the app if I had to guess.

Hi @willhuang thank you for the fast responses!
Yes, it is hosted on streamlit cloud. It is in a repo, yes. I restarted the app many times and the issue is still there. You can see the app at

https://dos-wpgpt.streamlit.app/

You can see it embedded at

Works great on any browser except for ios (safari and chrome)

Can you explain how you deal with dependencies. I would assume that there’s a requirements.txt file and then you can maybe try pinning the version

streamlit==1.18.1

Can you point me to your github?

I cannot point you to the git because its private (required by the person I am doing it for). I’m happy to create a new public one just to show you. Would that help?

I tried pinning the version to 1.18.1, did not help.

Thank you for the willingness to help!
I created a test app at
https://agiveon-testing-streamlit-srcmain-6i03bz.streamlit.app/
I embedded it at

The code I used for embedding is:

<iframe id="iframe" src="https://agiveon-testing-streamlit-srcmain-6i03bz.streamlit.app/?embedded=true" width="100%" height="1000"></iframe>

The github for it is

There is literally nothing on the webapp except for “Hello World”. Its showing everywhere EXCEPT for on ios browser. Seems extremely crucial to me.

1 Like

Hi, I don’t see anything on the chrome version of this either.

You are not seeing this?

Hi @agiveon , sorry I do see the hello world on both safari and chrome. I also see it on mobile phone.

You see it on ios safari? You must have 3rd party cookies enabled, right?

iOS chrome is built on safari basically.

basically or not, try it directly on safari and see the issue.

Hi guys. Any news on a solution?