I'm unable to install a particular package through conda and the error isn't very helpful

Is it possible to drop into a terminal to see what error occurs during the installation of the dependencies.

I’ve got an environment.yml file that works locally but seems to error out with very little information.

Any way to further debug this?

[11:10:36] πŸ–₯ Provisioning machine...
[11:10:36] πŸŽ› Preparing system...
[11:10:36] β›“ Spinning up manager process...
[11:10:39] πŸ”Œ Disconnecting...
[11:10:45] πŸ–₯ Provisioning machine...
[11:10:51] πŸŽ› Preparing system...
[11:10:57] β›“ Spinning up manager process...
[11:10:41] πŸš€ Starting up repository: 'dashboard_test', branch: 'main', main module: 'my_app.py'
[11:10:41] πŸ™ Cloning repository...
[11:10:43] πŸ™ Cloning into '/mount/src/dashboard_test'...
Warning: Permanently added the ED25519 host key for IP address 'XXXXX' to the list of known hosts.
[11:10:43] πŸ™ Cloned repository!
[11:10:43] πŸ™ Pulling code changes from Github...
[11:10:43] πŸ“¦ Processing dependencies...
Collecting package metadata (repodata.json): ...working... [2023-12-15 11:11:25.341406] bash: line 3:    11 Killed                  /home/adminuser/.conda/bin/conda env update -n base --file environment.yml
[11:11:25] ❗️ installer returned a non-zero exit code
[11:11:25] ❗️ Error during processing dependencies! Please fix the error and push an update, or try restarting the app.

Please share a link to your public github repo.

Remove the conda file and try this one:


--extra-index-url https://bcms.bloomberg.com/pip/simple

no this won’t work as pip doesn’t install some c++ dependencies hence the need for conda-forge.

seems like it’s a well documented issue that conda-forge doesn’t work in the streamlit app due to resource issues.

Is there a way to pay for more resources or get them allocated even temporarily to see if this actually solves the problem.

conda-forge related problems mentioned:

Have you even tried?
The Bloomberg repo provides wheels, therefore this should work.
I tried it in a python 3.11 docker container and installation worked.


We support and provide wheels for Python 3.8, 3.9, 3.10 and 3.11; Both 32 and 64 bits, for Windows, macOS, and most versions of Linux. These wheels now come bundled with the required C++ API, and a separate C++ API installation is no longer required.


I stand corrected! this worked!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.