ImportError: This app has encountered an error. The original error message is redacted to prevent data leaks. Full error details have been recorded in the logs (if you’re on Streamlit Cloud, click on ‘Manage app’ in the lower right of your app).

Please help

Hi @Davisonye, welcome to the community! :wave: :partying_face:

I’d encourage you to take a look through a related discussion:

tkinter requires a Linux package called libtk8.6 to be installed. To install such apt-get dependencies, include the dependency in a packages.txt file in your repo.

In your case, create a packages.txt containing:


I’ve done that.
Now it is stuck in the oven for over 1 hour

Thanks for reporting the issue. I’m following up with the team about delayed deployment times.

When I click on the manage app (at the bottom right). The image attached is what shows

Thanks again for sharing. I’ve reported the issue (that I also experienced with some of my apps) to our team who will take a look.

Hi @snehankekre sir I am getting ModuleNotFound Error please help me

This is my github repo

Hi @karthik6717 :wave:

Your error is unrelated to this thread. Please take a look at the following doc and create a new thread if it doesn’t solve your issue:

Hi @snehankekre, it is still the same. it hasn’t deployed yet.

Hey @Davisonye, thanks for your patience on this one! Engineering has confirmed that this is a Streamlit Cloud bug only affecting apps that have installed dependencies via apt / packages.txt. They’ve started working on a fix.

I will post an update here once the fix is released.

What alternative do I have please? What method do other people use to deploy to Streamlit cloud?

They use the same method you have. This is a bug introduced recently and affects all Streamlit Cloud users who use packages.txt. I would encourage you to wait till EOD by which time a fix should hopefully be out. We’re currently running tests on the fix and hope to release it soon.

Okay. Thanks

The fix has been released! :balloon: The solution is to delete your app on Streamlit Cloud and re-deploy it.

Thank you @snehankekre

Hi @snehankekre,
I got the same error (see attached image). Then, I deleted the app from streamlit cloud and redeployed it. But, still, I’m getting the same error. Please help me.

GitHub Link- GitHub - ShyamaleeT/glaucoma_app

Streamlit Link-

1 Like

can anyone help ,i have the same error

Try putting libgl1-mesa-glx or libgl1 on your packages.txt

same i am facing error