error and i cant upload my project / it works fine on local

ImportError: cannot open shared object file: No such file or directory

i keep getting this error every time i try to upload the project

this is the url

and this the github files GitHub - PrincessAzula1/s: A simple website for sentiment analysis made by abdulrahman and selman

Im new to coding so i pip install a lot of things and the end version worked in my local network but not when i try to upload it . i am using python btw

There are previous posts about this that can help you:

ok i check them out thank you
but i will keep this post up until i solve the problem

Hey @PrincessAzula1 Does your error solved???

no, most of the other posts says a similar thing about your requirements file but for mine i have a lot in it so i dont know what to do but ask here and hopefully someone tells me how to fix it since im a bit dummy in this

Hey just mention the dependencies which you have used in the code base. Remove the unnecessary things. If you are using the cv2 then mention it as opencv-contrib-python-headless.

Hope it works well !!!

Happy Streamliting :balloon:

so the only problem that i have is in my requirements folder? so just remove the unnecessary things and it would run normally?

Yes @PrincessAzula1. Just mentioned required dependencies for your application. Don’t forget to reboot the application after updating the dependencies file.

Hope it works well !!!

Happy Streamlit-ing :balloon:

ok i will do that and see thank you for responding btw

I think your packages.txt is being ignored. Try moving it to the root of the repository, as stated in the docs.

hmm u mean write the codes in

No, I mean moving the file packages.txt to the root of the repository.