ModuleNotFoundError: No module named 'keras.src.saving.pickle_utils'

Hi, I am trying to deploy my DL model using streamlit, but i am facing no module found error. The model was running successfully in the local.
Error:

Traceback (most recent call last):
File "/home/adminuser/venv/lib/python3.9/site-packages/streamlit/runtime/scriptrunner/script_runner.py", line 542, in _run_script**
    exec(code, module.__dict__)
  File "/mount/src/data-science-projects/app.py", line 9, in <module>
    classifier=pickle.load(pickle_in)
ModuleNotFoundError: No module named 'keras.src.saving.pickle_utils'

My github repo: GitHub - vijaybhargavkarnati/Data-Science-Projects: This repository contains all the code Data Science project and the code

can anyone please give me solution to this error.

Hi @vijaybhargavkarnati,

Thanks for sharing this question!

Have you tried loading the model directly?

from keras.models import load_model

model = load_model(model.h5)

yeah, i tried but it is showing

What file are you trying to upload?

Also, this is an error that’s currently being addressed in this thread as well and might be best to keep checking there as the solutions are offered.

.pdf files.