My app is not running anymore, due to altair issues

this is the error i am receiving while couple weeks ago it was running well and even on local host its running how can fix this issue i need help and guidance

Hi @turatsinzejunior83 :wave:

Thanks for reporting the issue.

Have you checked if Vega-Altair was indeed installed (via the requirements.txt file)? Also, have you tried deleting and relaunching the app.

If so, please send the link to the code, and we will have a look into it :slight_smile:

Best wishes,

1 Like

Hello, Charly

thank you for the feedback however I tried to install Vega-Altair via requirement.txt file but i was confused how to install it because trying to use Vega-Altair documentation which is not working kindly this is my code link GitHub - turatsinzejunior83/Diseases-Prediction

Either use latest streamlit version:


or if you have to stick with the older streamlit version, add this:


to your requirements.txt file.


Thanks, Franky! :slight_smile:

1 Like

Wow, that’s amazing support Your solution works well. fantastic job


1 Like

Glad you got it working!

It looks great! :hugs:

Happy Streamlit’ing! :balloon:

FYI: we’ve got an update coming to community cloud that will prevent this from happening in the future.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.