New app stuck in the oven


Seems like the problem is related to the subject of the folowwing thread:


Hi everyone,
I’m trying to create my first streamlit app with a GitHub repository, but the proccess is stuck showing only the message “Your app is in the oven”.
The log shows the following messages:

[12:23:44] 🖥 Provisioning machine...
[12:23:49] 🎛 Preparing system...
[12:23:54] ⛓ Spinning up manager process...
[12:24:01] 🎈 Inflating balloons...
[12:24:07] 📖 Unpacking Comic Sans RAR files...
[12:24:14] 🚧 Loading "Under construction" GIF...
[12:24:21] 🛠 Compiling <blink> tags...
[12:24:27] 📠 Initializing Java applet...
[12:24:34] ⏳ Please wait...

I have deleted and the created again new apps in order to get around the problem, but I still get stuck. I have waited up to 35 minutes with no changes.

My App:
GitHub repository: GitHub -jorsnow/streamlit_first_app

Thank you everyone for you time.

1 Like

Hey @jorsnow,

Your file does not seem to have any code.

Yes, that’s because I’m following one of the courses of Snowflake, which first creates the app without any code, resulting into one that would have one blank screen. The following step is adding the code.

I tried to generate the app with the code, but the same problem happened.

That being said, It seems that my problem is in relation to some general error, and thus has been linked to the thread about the aforementioned:

@jorsnow we’re looking into why the application is stuck. I’ll update the thread when we know more.

1 Like

Hi - I am going through the same Snowflake course and my app is stuck in the oven as well. I deleted and recreated repositories and files and waited 30mins but still showing “Please wait…”
2023-06-07 21_19_38-Inbox - - Outlook

Same here, My deployed app got stuck

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.