App Deployment Stuck in Oven

My app worked perfectly fine yesterday; however, now it does not update based on changes made to my code in Guthub. I have tried redeploying my app but it is stuck in the oven. Is this a current systematic problem?

Hey @Alex_White,

Can you share the link to your app and the GitHub repo?

Hi @Caroline , I seem to be having the same issue. I’ve tried deleting and recreating the app multiple times. The latest link to our app is at (it’s a private app), and the repo is at (it’s a private repo). Is there a service-wide outage right now?

The logs show it hasn’t progressed past “Processed dependencies!”, although it shows no errors in the logs up that point. We’re running Streamlit v1.23.0.

My repo is GitHub - ajpwhite78/wargame. I get the same message “Processed dependencies!” and then “Updated app!” but the app is still in the oven and frozen. Thanks!

Here is the app link

Hey Matt. Sorry to message you directly. Are you still having this problem? Thanks.

Hi @Alex_White ! We’re still having the issue, but seem to have found a short-term workaround while Streamlit figures out the underlying issue.

I created a new app using a different branch from our repo, and that did the trick. Something about the way Streamlit is saving apps, when we deleted the app, it clearly wasn’t fully deleting itself, since some sharing config would magically show up when we recreated the app. FYI @Caroline .

So yeah, I think the temporary workaround is to create a new branch in Github and use that for Streamlit.

Ok, thanks for the advice!

Thanks @matt.e.fay! This worked for me. Hopefully, Streamlit can fix the underlining issue.

Happy to help! @Caroline , if you could update this thread when you’re able to resolve the underlying issue, that’d be very helpful so we can remove this hack to get things working.

Hi all. Been facing this issue for last 5 hours. Tried @matt.e.fay 's suggestion and it didn’t work; an app from the new branch is still not deploying. Any suggestions?

I had to create a new repository, re-save my code and deploy from there. Worked successfully.

I’m experiencing the same issue. Looks like an issue at streamlit’s end.

1 Like

Thank you everyone for sharing more info on this! Our engineering team is working on a fix. I’ll keep you updated.

Update: this issue should now be resolved. Please let us know if you’re continuing to see this issue. Thank you!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.