No access for single private app on Streamlit Cloud

Hi

I have a private github repo which contains my source code and related files. I have deployed the app through Streamlit cloud and invited a couple of viewers. The viewers have got an email with a button link, but they can’t get access to the app, no matter what is tried. I believe one can host a single private app on Streamlit Cloud, right?

Ideally, an invited viewer should just be able to click the button link, authenticate and get access to the app. I tried using the app link in the viewer’s browser, but the address bar cyclically jumps from the streamlit cloud to app link, to no end. Has the streamlit policy changed on the use of a single private app?

All the viewers can only access the app if it is made public. How do I deploy the single private app?

Thanks in advance.

Hi @Shawn_Pereira

Yes, each user is allocated a quota of 1 private app. To deploy a private app, you’ll select a private GitHub repo that contains your app files. Such app will be accessible only to you, however you can click on the Share button on the top right to add email addresses of those you want to share your app with.

Hope this helps :slight_smile:

Thanks @dataprofessor, for your quick response. I tried all this before putting out the original SOS message. Is there any way that Streamlit can test this functionality out at their end?

Cheers

Hi, could you DM me details of the app (URL to the app) or if you’d like to share the app to me to see if it’s working.

If you have time, I would like to jump on a call to take a look at this. We might have introduced a regression in the authorization system, but I have not been able to reproduce it so far.

I have 1 private GitHub repo that runs fine on the Stream cloud.

Thanks @dataprofessor, @Alexandru_Toader and @shawngiese, for helping out.

Sorry for getting back so late.

I initially tried the private app with 3 viewers - it didn’t work for anyone. This morning, I re-tried the app, it worked only for 1 of the 3 viewers. I reset the app to public and then again to private and tried the app again. It worked for 2 viewers (the 3rd one will only be available tomorrow - will check that then).

I don’t know if it is an intermediate problem or if I did something wrong. But now its working.

Thanks, once again.

Cheers

2 Likes