Not able to run 2 streamlit application

I have tried using 2 streamlit applications using 2 ports.
It seems every time the application is only working when it is running on port 8501.

I tried running my application on another ports such as 8502/8503 but it does not work.

Get below output (No error occurs here) :


$ streamlit run TutorWebApp.py --server.port 8503

You can now view your Streamlit app in your browser.

Network URL: http://10.2.1.29:8503
External URL: http://104.155.152.129:8503


But when I browse this URL, the application does not appear on the browser and gives the below message :

This site can’t be reached

10.2.1.29 took too long to respond.

Try to run as:

streamlit run “TutorWebApp.py” 8503

I have tried this as welll. But still not working in the browser.

Can you open any other applications on those ports? I would check that out because it may be a permission issue, I had a similar problem on linux before. Take a look at the
Configuration - Streamlit Docs and then on your permissions. I hope this helps.

I’m facing the same issue, @cualr to check the permission issue, I initially run it on port 8501 then on 8502. streamlit app ran successfully on both the ports, just I need run the app one at a time. When I try to run two apps simultanously, I can’t.