Old (.py) Streamlit App Links doesnt work

Dear Community,

The public links with .py extension for my older (created in 2022) Streamlit apps do not work and generate the message:

“You do not have access to this app or it does not exist”

Does this only happen to me?


Have you tried to reinstall Streamlit?

Thank you for the response Oscar1,

I rebooted the app several times, and all the dependencies were reinstalled.
I think that the problem is that the link of the app changed: in the past, it was similar to the GitHub directory of the main app file, starting with “https://share.streamlit.io/” and ending with “.py”, and the present URL is quite different with the extension “.streamlit.app”.

Hi @KU_K . Have you renamed your GitHub repo name?

Thank you for your response,
Please consider the following unrelated links:

I found in a scientific publication (not mine):


My link:


Both give the same error message.

This error will raise may be if the app gets deleted or the app status set to private

The error is the same for the two links that I attached above. My app is functional and public, but in another URL with a different extension, the old URL seems to be deactivated without me changing it.

new URL: https://plazarid-ml-rc-frame-ml-stream-app-ve14wo.streamlit.app/

old deactivated URL: https://share.streamlit.io/plazarid/ml_rc_frame/main/ML_stream_app.py

But my question is that how it gets deactivated? @KU_K . Have you checked in your dashboard about the app logs of your older url??