"Please wait..." forever with HTML proxy

Hello, I have a problem with running my Streamlit app. I can access the server through browser, but the page is loading forever and I see “Please wait…”.

I tried out the things suggested in troubleshooting, but it did not help. My command is:

sudo streamlit hello --server.port 80 --server.enableWebsocketCompression=false --server.enableCORS=false --server.enableXsrfProtection=false

I need to run the app on a virtual machine, which is accessible from a head node. The head node uses a HTML proxy connecting port 80 of the VM to an outer url mypage.com/my_project. The domain name mypage.com has a corresponding IP address A.B.C.D.

If I run the application, I can see:

Network URL: http://W.X.Y.Z:80
External URL: http://A.B.C.E:80

where W.X.Y.Z is the address of the VM w.r.t. the head node and A.B.C.E is an address that is a little bit different from A.B.C.D which is the public IP of the head node. And so I tried setting browser.serverAddress to A.B.C.D but without any luck. The application is accessible, but still loading. This message is shown:

URL: http://A.B.C.D:80

If I use mypage.com/my_project instead, the application is still loading forever, it is accesible from http://mypage.com/my_project, but of course not from the address that streamlit shows after the start:

http://mypage.com/my_project:80

Could anyone help me please? :cry:

1 Like

Hi @Tomiinek, and welcome to the Streamlit community! :raised_hands:

I’m not sure about this issue but I’ve reported it to the Streamlit Devs. We’ll come back to you on this shortly.

Best,
Charl

Hi @Tomiinek

This article may help you?

Please let us know.

Charly