Plotly.express in requirements.txt, external dependencies

Hi, I’ve added a requirements text in github repo, and tried the following without success:
pip install plotly==5.22.0
pip install plotly
pip install plotly.express
pip install plotly-express
plotly==5.22.0
plotly
plotly.express
plotly-express

  1. https://z8ddzjj29t7c5cs7fiwyq6.streamlit.app/
  2. GitHub - Hassan-elSayyed/st_gm: Practice. Streamlit. 1st app.
  3. Error installing requirements. Click “Manage App” and consult the terminal for more details. If you still have questions, leave a message in our forums and we will get back to you ASAP.
  4. Python 3.11.5 • Streamlit 1.34.0

Welcome to the community, @Hassan! :wave:

You’d need to ensure your requirements.txt file avoids redundancy and includes the correct package names and versions. The content should look something like this:

plotly==5.22.0

After making sure your requirements.txt file is correct, you need to rebuild your Streamlit app to apply the changes.

Good luck with your app, and feel free to reach out if you need more help!

Charly

Hi Charly, thanks for the welcome and quick response. It worked fine this time, no rebuild needed. Cheers

Glad to hear, Hassan!

Happy Streamlit’ing! :balloon:

Charly

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.